ADS / OBD Testtool

  • Was soll denn das Ergebnis von "Test" sein?


    Zündung und Batterie werden vom Tester erkannt, nach dem Drücken auf "Test" schreibt er jedoch "Interface not found, timeout error !"


    Denke das ist nicht normal, oder?


    Interface ist das ADS/OBD von doitauto, verbunden über USB-->RS232 auf COM1


    Fahrzeug ist ein E36 318i EZ 5/96

  • So hab das Ganze nun mit dem ExpressCard Adapter versucht..


    Nachdem ich diesen Artikel Tipps & Tricks: ADS Interface funktionsfähig machen mit PCMCIA Karte gelesen hatte, hatte ich mich zum Kauf einer solchen Karte entschieden.


    Natürlich habe ich die von doitauto genommen da ich mir aufgrund dieser Beschreibung: "Dieses ExpressCard zu RS232 wurde Speziell für alle unsere Angebotene Diagnosegeräte...Konzipiert...mit diesem Gerät sollten nun Probleme der Vergangenheit gehören." eigentlich keine Komplikationen erwartet hatte. Jedoch gibt es die im oben verlinkten Artikel zitierte Registerkarte Ressourcen beim COM-Port nicht, sodass ich auch keine I/O Adresse herausfinden kann. <- hat hier vielleicht jemand eine Lösung?


    Hier meine Ergebnisse mit dem Test Tool:


    Sowohl im ADS als auch im OBD Modus erkennt das Tool zwar die eingeschaltene Zündung, jedoch nicht die Batterie (->Power off).


    Im ADS Modus bleibt das Ergebnis unverändert, sprich "Interface not found, timeout error !"


    Im OBD Modus jedoch bekomme ich o.a. Meldung nur zeitweise, manchmal bekomme ich "Interface found ! ... Test failed, bad response !"


    Fehlerspeicher auslesen klappt bei einigen Steuergeräten sowohl über USB Serial Converter als auch über Expresscard, jeweils nur über OBD, wobei bei der ExpressCard im INPA ebenfalls keine Batterie erkannt wird


    Über ADS klappts so und so nicht


    jemand Ideen? arbeite übrigens mit Windows XP x86

  • Welche Baureihe hast du den und was willst du auslesen ?
    Man kann bei den alten baureihen nicht immer alles auslesen und man muss auf die bmw DIS zurückgreifen.
    Wichtig ist das man bei den alten Baureihen eine alte Inpa benutzt die Version 4.4.7 und das alle einstellungen passen.


    Prüf das nochmal genau !!!!

  • Sorry für die späte Rückmeldung.
    Also es ist ein E36 318i EZ 05/96
    INPA Version ist 4.4.7 mit EDIABAS 6.4.3
    Über OBD und USB auf Seriell Adapter kann ich einiges auslesen, bloß DME und ein paar andere nicht
    Problematik bei ADS ist folgende:
    - bei USB auf Seriell:
    - Einstellung ADS in ediabas.ini: Weder Zündung noch Batterie werden in INPA erkannt, Auslesen bei keinem SG möglich
    - Einstellung OBD in ediabas.ini und Hardware=ADS in obd.ini: Batterie und Zündung werden in INPA erkannt, trotzdem kein Auslesen eines
    SGs möglich
    - Zündung und Batterie werden vom Testtool erkannt, jedoch Fehlermeldung 'Interface not found!'
    - bei ExpressCard auf Seriell:
    - selbe Problematik wie in den beiden ersten Punkten bei USB, jedoch wird keine Batterie in INPA erkannt


    Wie oben geschrieben klappt OBD beim USB Adapter in den meisten Fällen, verwende ich jedoch den ExpressCard Adapter, so ist mir auch über OBD kein Auslesen möglich (COM-Port ist definitiv der richtige ausgewählt!)


    Zum Testtool: Beim USB Adapter Erkennung von Batterie und Zündung jeweils bei OBD und ADS, jeweils mit dem Fehler Interface not found. Beim ExpressCard Adapter bei ADS Erkennung von Zündung, KEINE Erkennung von Batterie, Fehlermeldung Interface not found. Bei OBD ebenfalls Erkennung von Zündung und KEINE Erkennung von Batterie, Fehlermeldung Interface not found, zeitweise jedoch 'Interface found ... test failed, bad response'.


    DIS konnte ich leider nicht testen, da ich die Software weder habe. noch im Moment auftreiben kann.


    Ganz allgemeine Frage zum ExpressCard Adapter: Schenke ich diesem Artikel Glauben Tipps & Tricks: ADS Interface funktionsfähig machen mit PCMCIA Karte bringt mir der Adapter nur dann was, wenn ich in den Hardware Ressourcen die I/O Adresse herausfinden kann, was bei diesem Adapter scheinbar nicht der Fall zu sein scheint. Die Beantwortung dieser Frage ist mir besonders wichtig, da ich ansonsten am Überlegen bin den Adapter zurückzugeben und einen anderen zu kaufen.
    Und überhaupt ist mir unklar, warum ich bei OBD über den USB Adapter wesentlich bessere Ergebnisse erziele als mit diesem..

  • Hallo,
    ich habe das gleiche Problem wie oben beschrieben. Schon alles mögliche versucht, inkl. einer Neuinstallation von XP. Verwende INPA Version ist 4.4.7 mit EDIABAS 6.4.3 an einem Z3 (E36). Habe die Forenbeiträge von oben nach unten durch und wirklich alles mögliche versucht. Der ADS-Tester erkennt in OBD-Stellung das Interface, in ADS-Stellung die Fehlermeldung Timeout-Error. Habe XP auf einem alten Sony Laptop mit COM-Port laufen. Adresse und Interrupt stimmen. Habe echt keine Idee mehr. Könnte es sein, daß das Do-It-Auto Interface einen Defekt hat?

  • Man braucht einen alten Laptop wo den RS232 Anschluss hat.
    COM muss auf 1 stehen.
    Interface auf ADS


    OBD.INI
    COM 1
    Hardware : ADS


    Ediabas.ini
    STD:OBD ---------> ändern auf ADS


    Im Ordner Ediabas/Hardware nach ADS suchen und das Setup ausführen.
    Ediabas Version geht nur die 6er


    Und bei manchen alten Baureihen gehen nicht alle SG auszulesen. Hier braucht man dann BMW DIS damit kann man dann Motor und auch alle anderen SG auslesen.

  • Hallo,
    danke für die Antwort. Ich glaube all diese Voraussetzungen zu erfüllen. Beim Laptop handelt es sich um einen alten Sony Vaio mit eingebautem Com-Port. Ansonsten habe ich die Einstellungen für ediabas.ini und obd.ini so abgeändert. Zudem anderes Kabel probiert.....
    Bin wirklich ratlos.

  • Hallo,
    danke für die Antwort. Ich glaube all diese Voraussetzungen zu erfüllen. Beim Laptop handelt es sich um einen alten Sony Vaio mit eingebautem Com-Port. Ansonsten habe ich die Einstellungen für ediabas.ini und obd.ini so abgeändert. Zudem anderes Kabel probiert.....
    Bin wirklich ratlos.


    Um welches Fahrzeug geht es den genau und welches Bauj.

  • um einen BMW Z3 Bj. 1/97 - Ich komme per INPA auf die Steuergeräte für Motor, Airbag und Wegfahrsperre. Kombiinstrument, ABS... nicht möglich. Mit dem ADS / OBD Testtool bekomme ich bei der ADS-Einstellung am Interface die Fehlermeldung "Interface not found, timeout error!"
    Beim Z3 ist Pin 15 an der 20pol Buchse belegt, somit sollte ADS funktionieren.

  • um einen BMW Z3 Bj. 1/97 - Ich komme per INPA auf die Steuergeräte für Motor, Airbag und Wegfahrsperre. Kombiinstrument, ABS... nicht möglich. Mit dem ADS / OBD Testtool bekomme ich bei der ADS-Einstellung am Interface die Fehlermeldung "Interface not found, timeout error!"
    Beim Z3 ist Pin 15 an der 20pol Buchse belegt, somit sollte ADS funktionieren.


    Welche SG lassen sich auf ADS auslesen :
    Welche auf OBD ?

  • habe eben nochmals beides getestet. Umstellung an Interface, in OBD.ini und ediabas.ini. Folgede Steuergeräte können jeweils ausgelesen werden:
    ADS:
    MS410DS3
    ZAE2
    EWS
    OBD:
    MS410DS3
    ZAE2
    EWS