D+K CAN USB INTERFACE Fehler

  • hallo, habe ne Frage.. Mein Interface hat bis vor kurzem ohne probleme Funktioniert, seit neustem kriege ich andauernd Fehler meldungen
    Bei NCS Expert IFH-0010: Datenuebertragung Interface/Steuergeraet gestoert
    bei Tool32 IFH-0018: Initialisierungsfehler des Interface-Handlers
    Bei NFS IFH-0002: Interface ist nicht angeschlossen oder meldet sich nicht
    Inpa Funktioniert einwandfrei, NCSExpert funktioniert mal und mal kommt der Fehler, habe schon mehrmals alles neu installiert, kann es sein dass das interface defekt ist?
    die Fehler kamen obwohl nichts verändert wurde, es wurde dass selbe Auto Codiert wie vorher, Datenstand wurde auch schon aktuellisiert von SP Daten 45, Neues Programm wurde dann Installiert BMW Standardtools 2.11, selber fehler.
    gestern z.b E60 2008 ausgelesen mit inpa, dann NCS angemacht, F1 dann F3, und schon kam der Fehler
    10 minuten später dass selbe, dann kam ich rein, Nettodat ausgelesen, einmal Fehler, beim zweiten mal hats geklappt. Nettodat schreiben und wieder der fehler, einige zeit später noch geschafft per FSW_PSW zu codieren.
    bin schon am verzweifeln, weiss jemand weiter?
    Gruss ?(

  • Hallo,


    alle Deine IFH-Fehler deuten eigentlich darauf hin, dass die Software nicht sauber mit dem COM-Port kommunizieren kann, warum auch immer das so ist: Bei mir war es ein Logitech-Treiber, der manchmal diesen Konflikt verursachte.


    Ich habe daraufhin den COM-Port des Interfaces geändert auf COM 3 (vormals COM 2), die FIFO-Buffer Einstellungen wieder auf den Wert "8" gesetzt (Rx + Tx) und den COM 3 natürlich auch in der OBD.INI eingetragen....seitdem ist der Fehler nicht wieder aufgetreten.


    Normalerweise findest Du im Verzeichnis EDIABAS/Doku eine pdf.-Datei mit Names "FAQ.pdf", da steht der Hintergrund für die einzelnen Fehler des Interface-Handlers recht brauchbar beschrieben.


    Ich hoffe, es hilft Dir weiter.

    Freude am Fahren...solange alles funzt :)

  • eigentlich dürfte es keine konflikte geben da es ein reiner diagnose netbook ist wo nichts drauf ist :) aber werde morgen als erstes den treiber nochmal neu installieren und schauen ob es hilft, wenn nicht dann deine lösung ausprobieren. jedoch weiss ich nicht was du mit dem Fifo buffer meinst, wie finde ich den?


    gruss

  • Hallo,


    die Einstellungen für den FIFO-Buffer findest Du im "Gerätemanager --> Anschlüsse (COM und LPT) --> Doppelklick auf Kommunikationsanschluss (COM x) --> Anschlusseinstellungen --> Erweitert --> Häkchen vor FIFO-Puffer verwenden --> darunter die beiden "Schieber" für Empfangs- und Übertragungspuffer auf "8" setzen und alle Fenster mit "OK" schliessen.


    Das war jetzt aus dem Kopf für Windows 2000; ist für XP und neuer ähnlich. --> Du findest es sicherlich ;)


    Das Einzige, was ich nicht so recht nachvollziehen kann, ist warum Dein INPA einwandfrei funktioniert und nicht auch irgendeinen IFH-Fehler ausspuckt ....eigentlich benutzen doch alle Programmteile den gleichen EDIABAS Server und die gleichen Einstellungen ?( :?:

    Freude am Fahren...solange alles funzt :)

  • Mal eine kurze frage habe den selben fehler jedoch nicht bei allen autos , mein e39 und e36 geht alles ohne probleme ob Inpa oder NCS... habe noch einen e82 und da macht der nun diesen fehler bein Inpa und bei NCS sagt er mirdie Fehlermeldung" Fahrgestellnummer..."fehlerhaft .. hoffe ihr konnt mir da weiterhelfen,