Verzwickter Fall: E89 + DCAN + INPA + IFH-0009

  • Hallo,


    Habe einen E89 und das do-it-auto EDIN K+CAN USB Interface. Ich probiere schon seit zwei Tagen ohne Erfolg eine stabile Verbindung zum Auto herzustellen und bekommen den IFH-0009 Fehler in INPA wenn ich probiere Fehler auszulesen. Ich habe saemtliche Kofiguration ein Dutzend mal eingestellt und ueberprueft. Nach dem ganzen rumspielen kommt inzwischen sogar eine Airbag Warnleuchte. Ich hoffe mal dass die nicht durch fehlerhafte Kommunikation von INPA verursachte wurde, sondern nur durch eine schwache Batterie waehrend dem Verbindung herstellen versuchen (obwohl ein Ladegeraet angeschlossen ist) (Mit wieviel Ampere sollte man laden? 2,6,12?). Ich beschreibe hier mal meine Konfiguration in der Hoffnung dass jemand den Fehler findet, und ich mich dann mit INPA hoffentlich um den Airbag kuemmern kann um nachzuschauen ob ich ihn zur Werkstatt bringen muss oder nicht. Ich hab alle Loesungsmoeglichkeiten in der FAQ.pdf im INPA Verzeichniss probiert - ohne Erfolg und bin inzwischen schon am Zweifeln ob es am Kabel liegt (unwahrscheinlich aber mir faellt nichts mehr ein).


    - Hardware ist ein dezidiertes Thinkpad T61 mit 32-bit Windows XP das nur fuer Diagnose Zwecke installiert worden ist. Keine VMs oder sonstiges.
    - Software ist das empfohlene "EDIABAS/INPA EA90X mit Update bis 2012" also BMW Standard Tools 2.4.0 + Update.exe ES-76. Spaeter hab ich es dann mit Standard Tools 2.11 + Update.exe ES-76 probiert um die neuen tools Versionen zu haben.
    - FTDI Treiber 2.08.24 von ftdichip.com installiert
    - OBDSetup.exe ausgefuehrt
    - Ich habe im Forum noch eine D-CAN.exe gefunden aber nirgend eine Anleitung wofuer die gut ist. Ich hab die .exe nicht ausgefuehrt. Muss man? Treiber: Treiber für DCAN Interface
    - Kabel liegt auf COM3
    - In edibias.ini steht
    Interface=STD:OBD
    - in obd.ini steht
    Port=Com3
    Hardware=USB
    RETRY=ON
    - Wartezeit auf 1ms runtergesetzt wie in den meisten tutorials beschrieben


    Wenn ich das Kabel einstecke leuchtet es fuer 1 Minute, danach geht die LED aus. INPA kriegt eine Verbindung zum Auto und zeigt den Batterie und den Zuendungspunkt schwarz an wenn man die Zuendung einschaltet. Beim Fehler auslesen oder Steuergeraete ansprechen kommt zu 99% Fehler IFH-0009 und manchmal ein anderer IFH (0003 und andere).


    Dinge die ich probiert habe (alles ohne Erfolg):
    - verschiedenste Software Versionen, deutsch und english, aber im Endeffekt bin ich bei Standard Tools 2.11 + Update.exe ES-76 geblieben
    - obd.ini nach C:\Windows kopiert, obwohl laut FAQ.pdf bei neuen Versionen es nur in C:\EDIABIAS\BIN\ sein muss
    - Verschiedene USB Ports benutzt
    - Rechner komplett neu installiert
    - Kabel im Geraetemanager auf COM4 statt COM3 gemappt und obd.ini angepasst
    - Kabel auf COM1 gemappt und ignorieren des Konflikts (Empfehlung der FAQ.pdf)


    Vielen Dank fuers Helfen. :)

  • Noch eine Info: Den beiliegenden Adapter verwende ich nicht, denn mein E89 muesste ja per CAN ansprechbar sein und nicht per K-LINE. Anders in manchen Bildern von dem Kabel auf der Webseite hat meines einen Pin8 (also alle 16 Pins). Ich nehme an das ist so weil es eine neue Version des Kabels ist, und somit kein Problem darstellt.

  • Weiters habe ich probiert INPA zur Verbindung zu ueberzeugen bei


    - Eingeschalteter Zuendung
    - Eingeschalteter Zuendung + Batterieladegaeraet
    - Eingeschalteter Zuendung + Motor lauft


    In allen 3 Situation erkennt INPA die Zuendung, aber bekommt Fehler IHF-0009, IHF-0003, IHF-0010

  • Gerade noch einen Test mit einem anderen Auto desselben Typs gemacht und die gleichen Fehler bekommen. Es liegt also nicht am Auto, sondern an der Software Konfiguration, dem Laptop oder dem Kabel. Zu 99% liegen solche Fehler an der Konfiguration der Software, nur weiss ich leider nicht mehr weiter nachdem ich das ganze FAQ.pdf durchgearbeitet habe.

  • Habe inzwischen die D-CAN.exe im diesem offiziellen Post (Treiber: Treiber für DCAN Interface) ausprobiert, und festgestellt das sie dazu dient das interface zwischen CAN und K-Line umzuschalten. Das Tool läuft allerdings nicht erfolgreich durch und ich vermutlich das es nicht für das do-it-auto Interface gedacht ist, weil bei do-it-auto haben wir ja einen physischen Vorschaltadapter um von CAN auf K-Line zu wechseln.

    Einmal editiert, zuletzt von thomasthomas ()

  • Bei dem neuen K + DCAN Interface fehlt der Pin 8 und bei dir sind alle vorhanden und warscheinlich gebrückt also Pin 7 + 8


    Ältere Baureihen werden mit dem K + DCAN und dem Adapter ausgelesen. ( Hier ist Pin 7 + 8 gebrückt KK- Line)
    Baureihen bis 2008 mit DCAN ohne Ethernet Enable kann Pin 7 + 8 noch zusammen bleiben da am Fahrzeug der Pin 8 fehlt.
    Baureihen ab 2009 mit DCAN und Ethernet Enable muss der Pin 7 für DCAN und Pin 8 für Ethernet Enable getrennt sein sonnst kommt es zu störungen.

  • Das heisst das Interface ist alt? Ich habs vor 1 Woche bei do-it-auto bestellt. Bei Empfang ist mir der Vorhandene Pin 8 aufgefallen und ich habe do-it-auto kontaktiert. Die Antwort: "es ist schon das neue generation pin8 ist nicht belegt hier liegt das ethernet pin"


    Ist es jetzt die neue oder die alte Generation Kabel die ich habe?

  • Ok, das heisst ich hab Generation 3 von Interface, wenn ichs richtig verstehe.


    Generation 1: Pin7+8 gebrueckt
    Generation 2: Pin 8 abgezwickt
    Generation 3: Pin 8 nicht belegt oder sonst irgend wie ein smarter Pin


    Dann kann ich das Kabel schon mal ausschliessen. Jemand ne Idee woran es denn dann noch liegen kann?

  • Inzwischen 3 verschiedene Fahrzeuge probiert und 5 verschiedene Softwarepakete: EA80X, EA90X, Standard Tools 2.4, Standard Tools 2.11, jeweils english und deutsch, jeweil mit und ohne ES-76 2012 Update.


    Immer IFH-0009, IFH-0003, IFH-0010 Fehler.

  • Folgendes ist mir aufgefallen: Der Batterie und der Zuendungsindikator gehen immer nur gleichzeitig an nachdem die Zuendung eingeschalten ist. Muesste der Batterieindikator nicht unabhaengig von dem Zuendigsindikator schon vor der Zuendungsstellung EIN was anzeigen?

  • Noch eine Idee: Kann es sein das der beiliegende Adapter in dieser Generation der Interface ( mit Pin 8 ), nicht dazu da ist von DCAN auf K-LINE "runterzuschalten", sonder von Ethernet-enabled OBDII Ports (F-Serie) auf DCAN runterschalten. Ich hab einmal kurz mit dem Adapter aufsatz probiert, aber 99% meiner Versuche waren ohne Adapter in der Annahme dass der Adapter nur fuer K-Line gebraucht wird.

  • Update: Habe versucht auszuschließen dass es an dem USB-Port liegt. Das Thinkpad T61 hat 3 USB 2.0 Ports. Es spielt keine Rolle an welchem das OBD Kabel angeschlossen ist, bei allen drei ist die Verbindung instabil. IFH-0009/3/10
    Datentransfers erledigen die USB-Ports einwandfrei, eine Maus lässt sich an allen drei anschliessen und funktioniert auch. Die USB Ports scheinen also in Ordnung zu sein.